Linux on Atom based devices

Linux on Atom based devices

TechTablets Forums General General Discussion Linux on Atom based devices

This topic contains 296 replies, has 49 voices, and was last updated by  jaranya500 6 months ago.

Viewing 15 posts - 61 through 75 (of 297 total)
  • Author
    Posts
  • #30889

    xjesus
    Participant
    • Posts: 30

    My last test on 16.04 with 4.4.4 kernel and the last pinguybuilder 4.3.6beta, removing patch for RT8723bs and vitualbox-guest-utils has resulted in a login screen (lightdm) where it only lets me choose the user “other…” and if I manually enter live or “usu” (my user on the Virtualbox I built the ISO) I can’t login. I’ve tried blank passwords as well.

    https://drive.google.com/file/d/0B4TUehAb_iPFT1RRREpRMFZWQkk/view?usp=sharing

     

    My last test on 14.04 with 4.4.4 kernel is working but as I said I can’t install/compile patches, I suppose it’s expecting the new upgraded compiler.

    I’m downloading your new Pinguy Mini Atom and will try it.

    I tried some days ago 4.4.5 , 4.4.6 and 4.5 kernels and they didn’t work. But I might try again if I find the time.

    #30891

    xjesus
    Participant
    • Posts: 30

    If someone could test this you would be doing me a huge favour. If it boots and works I will re-package my distro and re-release it with the patches. Pinguy_OS_14.04.4-3-LTS-Mini_Atom.iso

    It doesn’t work on my Teclast X98Plus A5C8

    This is where it gets stuck:

    https://drive.google.com/file/d/0B4TUehAb_iPFNUJFYjdlVGZtaDA/view?usp=sharing

     

    It works in Virtualbox though.

    #30916

    Daniél Lecoq
    Participant
    • Posts: 41

    pinguy: Sorry about the delay. Something came up.

    Yes, I get the same result as xjesus. Same device. Teclast X98 Plus (A5C8)

    Also, when choosing the OS to boot, it’s oriented the correct way. Portrait mode. But when it starts to boot, it turns upside down.

     

    https://www.dropbox.com/s/qxd9xv5tr4byajq/2016-03-26%2009.33.46.jpg?dl=0

    https://www.dropbox.com/s/1u5vlg1u300qxh2/2016-03-26%2009.34.08.jpg?dl=0

    #31089

    pinguy
    Participant
    • Posts: 14

    My last test on 16.04 with 4.4.4 kernel and the last pinguybuilder 4.3.6beta, removing patch for RT8723bs and vitualbox-guest-utils has resulted in a login screen (lightdm) where it only lets me choose the user “other…” and if I manually enter live or “usu” (my user on the Virtualbox I built the ISO) I can’t login. I’ve tried blank passwords as well.

    @xjesus
    http://forum.pinguyos.com/Thread-Auto-Login-Not-Working

    #31090

    Anonymous
    • Posts: 12

    @xjesus I’ve been trying to download the XJ16.04-16.03.23-dist.iso for a few days. but I always endup with wrong md5 and sha256.

    So downloading again. However, I get the same md5 and sha256 with the new download. May the md5 and sha256 you added to https://sourceforge.net/projects/xjubuntu/files/16.04%2064%20bits%20-%20Very%20stable%20Beta/ be wrong, or should I just try yet another download?

    I’m getting

    Size: 2813493248 bytes(2683 MB)

    sha256: 88FC5AC6A38EEA5DBBE6AA913B479B7570A0066D919A9C1661612EB03BADC436

    md5  : fa745fed74ce5435bd16859692e57512

    Could you do a quick check for me, if those on sf.net are correct and I should try yet another download or if the ones I got are OK.

    Thanx.

    #31094

    xjesus
    Participant
    • Posts: 30

    Yes, the upload was incomplete. Now it should be all right. Thank you for warning me.

    This morning I’m uploading a new release based on 4.6rc1 kernel so please wait and test this.

    #31095

    Anonymous
    • Posts: 12

    Cool! Will first test the *23 iso, when I manages to get it down. At the moment sf.net doesn’t find any mirrors for it, but I guess they will show up shortly, since it says the iso was uploaded 10 minutes ago.

    Got the *21 iso on a USB stick, so gonna play with it now.

    #31137

    Massimo
    Participant
    • Posts: 24

    I will test it on Teclast x98 Air 3G C5J6.

    I will use Rufus in order to run that in Live Mode..

    Edit: with Rufus burn it as ISO Image it shows an error, see the attached image.

    Attachments:
    You must be logged in to view attached files.

    Ultrabook: Acer S3-391 Win 10 x64 + Deepin 15.1.1 Smartphone: Oneplus TWO A2003 Tablet: Teclast X98 Air 64Gb 3G (C5J6, Uefi Bios 2.02) Dual Boot Windows 10 ITA + Android 5 Lollipop By Mirek190 eReader: Kindle Paperwhite

    #31206

    xjesus
    Participant
    • Posts: 30

    @pinguy

    Thanks! It’s solved now.

    I’m still struggling to patch the WiFi. It’s getting me mad. I’m sure the problem is that I’m not applying the patch correctly. Can somebody help me?

    I’ve opened a ticket issue here: https://github.com/hadess/rtl8723bs/issues/61

     

    #31208

    Anonymous
    • Posts: 12

    I got no problem creating the USB with Rufus, all tried so far boots, I get to chose live mode or install mode. Then it starts the Linux system. But none of them actually boots into a graphic Linux system.

    Tried one from pinguy and 2 from (03.21 and 03.23) from xjesus.

    Anyone got any hint on how to get it to boot to something usable, from where I can start tinkering?

    Teclast X98 Plus A5C8

    #31209

    xjesus
    Participant
    • Posts: 30

    Hi Daniel, the last release (03.27 or 03.28) boots to the graphical interface on my Teclast X98 Plus A5C8, with booth 14.04 and 16.04. They don’t have the patches for the WiFi applied that hangs the tablet boot process.

    03.21 and 03.23 were booting only with 14.04 because it didn’t include the patches.

    When I say 14.04 I mean this folder:

    https://sourceforge.net/projects/xjubuntu/files/Tablets%20Intel/

    When I say 16.04 I mean this other folder:

    https://sourceforge.net/projects/xjubuntu/files/16.04%2064%20bits%20-%20Very%20stable%20Beta/

     

    The basic difference up until now is that the gcc-compiler was newer in 16.04 and was letting me install the WiFi patches but without other patches needed as well to avoid the hang of the boot process.

    Right now I’ve included the last gcc-compiler in 14.04 too so I will be able to compile everything. But still I have problems with the “patch -p1 < …” commands, and that’s the issue I’ve asked on github.

     

    #31211

    Anonymous
    • Posts: 12

    oh, xjesus. I think you made a slight typo in the newest files for the “very stable beta”, or do you have a time machine 😉
    XJ16-16.04.28-dist.iso < 22 hours ago 3.3 GB 44 weekly downloads i
    XJ16-16.04.28-dist.iso.sha256 < 23 hours ago 89 Bytes 0 i
    XJ16-16.04.28-dist.iso_kernel4.6rc1.md5 < 23 hours ago 57 Bytes

     

    But grabbing 03.27 from Intel Tablets category, and also unetbootin

    #31212

    Anonymous
    • Posts: 12

    I can’t see the pastebin you referred to on github, but usually, with patches, you need to rewrite them slightly if that message pops up.

    Feel free to send me a link to the patch and I’ll have a look.

    #31214

    xjesus
    Participant
    • Posts: 30

    Ups! Now the link is correct: http://pastebin.com/uEFdgj3h

    The patch is https://github.com/hadess/rtl8723bs

    I can install it with make , sudo make install , etc.

    But then as the instructions say, you have to apply the patches in the “patches” folder. And that’s where I’m stuck. I do “patch -p1 < … ” with all the patches and always get errors like the pastebin one.

    #31217

    Anonymous
    • Posts: 12

    In this case, you need to have the patch in the correct folder. In the mentioned case.

    The folder above

     

    include/linux/
    and
    kernel/power/

    I don’t have any running Linux at the moment, so can’t test, but… Hopefully the 3.27 is downloaded soon, and hopefully running… Then I can see what I can do.

    Sometimes it’s easier to split up the patches, remove the path info, and put the patch in the exact folder where the changed file is, or if it’s just minor changes, do the changes manually.

    — a/include/linux/pm_qos.h
    +++ b/include/linux/pm_qos.h
    @@ -126,6 +126,8 @@ void pm_qos_update_request(struct pm_qos_request *req,
    s32 new_value);
    void pm_qos_update_request_timeout(struct pm_qos_request *req,
    s32 new_value, unsigned long timeout_us);
    +void pm_qos_cancel_request_lazy(struct pm_qos_request *req,
    + unsigned int timeout_us);

    As here, go to the file “/include/linux/pm_qos.h”

    Scroll down to line 126 and find the line “s32 new_value, unsigned long timeout_us);”

    and directly after add the 2 lines
    void pm_qos_cancel_request_lazy(struct pm_qos_request *req,
    unsigned int timeout_us);

    Then save. And do the same for other changes. While more work, it will at least put the correct stuff in the correct place.

Viewing 15 posts - 61 through 75 (of 297 total)

You must be logged in to reply to this topic.

Lost Password